4518 - 개강 연기

Time Limit: 1s Memory Limit: 128MB

Submissions: 315 Solved: 106
Description

XX대학교는 개강을 n일 연기하기로 결정하였다.

원래 개강했어야 할 날짜가 M월 D일이었을 때, 연기된 개강일은 언제인지 계산해보자.

이 때, 2월은 28일까지만 있는 것으로 한다.

Input

* Line 1 : 입력의 갯수 N (1 ≤ N ≤ 1000)

* Line 2~N+1: 개강월 M, 개강일 D, 개강 연기일 n (0≤n≤100000)

Output

* Line 1~N : 개강월, 개강일

Sample Input
2
3 2 14
3 2 72
Sample Output
3 16
5 13
Hint

switch 문은 break 가 없으면 다음 case를 실행해버린다는 성질을 이용하여 아래와 같이 만들 수도 있습니다.

#include <stdio.h>
int main()
{
	int m;
	scanf("%d", &m);
	switch(m){
	    case 2:printf("28");break;
	    case 1:case 3:case 5:case 7:case 8:case 10:case 12:printf("31");break;
	    default:printf("30");break;
	}
	return 0;
}
#include<stdio.h>
int main(){
	int m, d=0;
	scanf("%d", &m);
	switch(m){
	    case 1:case 3:case 5:case 7:case 8:case 10:case 12:d=d+1;
	    case 4:case 6:case 9:case 11:d=d+2;
	    default:d=d+28;
	}
	printf("%d",d);
	return 0;
}